Reports service experiencing delays

Incident Report for ChartHop

Resolved

This incident has been resolved.
Posted May 02, 2023 - 12:45 EDT

Monitoring

Reports are now working again.
Posted May 02, 2023 - 12:40 EDT

Identified

We are currently experiencing slowness when generating reports. We have identified the issue and are working to resolve this.
Posted May 02, 2023 - 12:21 EDT
This incident affected: User Interface.