UI failing to load

Incident Report for ChartHop

Postmortem

Summary

An upgrade to a third-party component contained an unexpected additional header value. The header value was not accepted by our API servers leading to a CORS error.

Details

One of our third-party javascript components introduced support for the baggage HTTP header. The header was not accepted by our cross-origin allowed headers policy and the Access Control headers were not returned to prevent potential security issues. Browsers rejected the API request from the UI due to the lack of Access Control headers.

Impact

The UI was inaccessible to all customers during this outage. API requests were still working and data was still ingested into the system (e.g. Payroll, ATS, and Equity.)

Posted Nov 09, 2022 - 15:28 EST

Resolved

UI failing to render for all customers
Posted Nov 09, 2022 - 12:40 EST
This incident affected: User Interface.